Tuesday 31 May 2011

How to mount an ISO image file as a filesystem in AIX


In AIX you "dd" the ISO file into a raw LV, then mount the LV as a filesystem.
Here are the steps for copying the ISO named "image.iso" into "/cd1iso", a JFS filesystem:
1. Create a filesystem with size slightly bigger than the size of the ISO image. Do NOT mount the filesystem:
# /usr/sbin/crfs -v jfs -g rootvg -a size=800M -m/cd1iso -Ano -pro -tno -a frag=4096 -a nbpi=4096 -a ag=8


2. Get the logical volume name associated with the new filesystem:
# lsfs | grep cd1iso (assume it is /dev/lv00)


3. dd the ISO image into rlv00 (raw lv00):
# dd if=image.iso of=/dev/rlv00 bs=10M


4. Alter /cd1iso stanza in /etc/filesystems => vfs=cdrfs and options=ro 


    /cd1iso:
            dev            = /dev/cd1_lv
            vfs             = cdrfs
            log             = /dev/loglv00
            mount           = false
            options         = ro
            account         = false


5. Mount the file system :
# mount /cd1iso


6. When finished, remove the filesystem:
# rmfs /cd1iso

3 comments:

  1. http://studyviareading.blogspot.in/
    Visit and give your suggestionsa

    ReplyDelete
  2. The requested information is good enough. And then by reading this feel good, were constantly writing and Share Information.
    davv cet coaching in Indore

    ReplyDelete
  3. Awsome this article is very nice
    You are doing great job,keep it up!
    Interesting stuff to read it is really helpfull..
    top b.tech college in Srinagar

    ReplyDelete